Subject: Re: BUILDLINK_DEPENDS.gtk2 >=2.4.0?
To: grant beattie <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 04/14/2004 20:40:04
On Thu, 15 Apr 2004 04:01:45 +1000
grant beattie <> wrote:

> does BUILDLINK_DEPENDS.gtk2 really have to be >=2.4.0?
> I wouldn't claim to be a heavy user of gtk2, but I locally hacked
> gtk2/ and have vlc and firefox-gtk2 built against
> gtk2+-2.2.4nb3 without any problems.

The shared library major number changed, so bumping the version was needed
to ensure you rebuilt all the packages depending on it.  Not doing so
means that you can easily end up with software that doesn't work, because
they won't find the required shared library.  (And I hit this problem).

Though... they claim that 2.4 is _binary_ compatible with 2.2...  so maybe the
package could be modified to install a symlink between
and, downgrade the required version, and hope everything
works?  (I don't know if this could work, and it's probably late now to do

(This means that some more symlinks are needed, for example to let it find
the engines, pixbuf loaders, etc.)

> is this a case where BUILDLINK_RECOMMENDED is useful? I don't remember
> how that stuff works...

Don't think so.  I'm still not sure about the semantics of that variable,
(I should read Packages.txt...)


Julio M. Merino Vidal <>
The NetBSD Project -