Subject: Re: CVS commit: pkgsrc/graphics/gimp
To: Martin Husemann <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 04/10/2004 07:37:42
On Sat, 10 Apr 2004, Martin Husemann wrote:

> On Sat, Apr 10, 2004 at 10:13:27AM +0200, Juan RP wrote:
> > I wanted to be sure that gimp requires and links to the correct fontconfig
> > version.
> WTF does it need a incompatible version at all? This should by all means
> be avoided, IMHO.
> This font issue is getting out of controll, a more general solution is needed,
> like not building fontconfig in src/x11 or xsrc at all.

Usually, when you replace a system library, you give the replacement
a different name, or put it in a private directory, or take other
steps to ensure that applications can get the one they want. Consider
"curses" vs. "ncurses". The freedesktop developers obviously don't
care about that at all.