Subject: Re: perl modules need better, non-open dependencies
To: grant beattie <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/09/2004 23:57:49
On Sat, 10 Apr 2004, grant beattie wrote:

> > So you use modules from 5.8 with perl 5.6? And perl 5.6 modules with perl
> > 5.8?
> no.
> > What does perl -V tell you? (Somehow it must have been configured to know
> > those paths for @INC.)
> that's why I think your build is broken - I don't think that should
> happen.

That ("I don't think that should happen") is exactly why sent my first
email. I think I agree. I don't think that should happen. (I don't think
my "build is broken".)

Te packages allow it. Please see the first email.

The DEPENDS are open-ended. So you can easily make packages and install
them on another system (or reinstall on same system).

I don't see anything stopping you from installing perl 5.6 with perl 5.8
modules or visa versa.

I sent the first email to ask for ideas on how this can be improved.

   Jeremy C. Reed