Subject: perl modules need better, non-open dependencies
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/09/2004 12:16:50
reed@puget:/usr/pkgsrc/new/inkspace$ perl -e "require XML::Parser"
Can't locate XML/ in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.8.3/i386-linux /usr/lib/perl5/site_perl/5.8.3
/usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl
/usr/lib/perl5/5.8.3/i386-linux /usr/lib/perl5/5.8.3 .) at -e line 1.

I have: p5-XML-Parser-2.31nb1 it is installed to

But the requirements say perl>=5.0

Maybe this is wrong:

BUILDLINK_DEPENDS.perl+=        perl>=${_PERL5_REQD}

Or maybe the default @INC should add other directories?

   Jeremy C. Reed