Subject: remove devel/eXdbm ?
To: None <>
From: Manuel Bouyer <>
List: tech-pkg
Date: 04/08/2004 21:54:01
Any objection if I remove devel/eXdbm ?
This package was introduced because it was a requirement for gpsim,
nothing else in pkgsrc use it.
Newer versions of gpsim include eXdbm (and install in a way which conflicts
with devel/eXdbm). In addition, quoting gpsim-0.21.2/eXdbm/README.gpsim:
gpsim version 0.20.14
Starting with this version, eXdbm will now be distributed as part of
gpsim. The purpose for this is to simplify install issues that gpsim
users have had with eXdbm in the past. Also, a few minor bugs have
been fixed with eXdbm by the gpsim development team. Unfortunately,
the original authors do not appear to be supporting eXdbm any longer
(hmm, that's probably a hint). eXdbm, like gpsim, is licensed under

Of course I could add the fixes from gpsim to devel/eXdbm (I looked,
it's only things like size_t vs int, uninitialised variables, etc ...)
but it would make maintenance harder in the future, for no real benefit.

So I propose to make gpsim conflict with eXdbm, and remove devel/eXdbm.
Comments ?

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference