Subject: Re: mod_perl (ap-perl) and perl version
To: grant beattie <>
From: Pierre Bourgin <>
List: tech-pkg
Date: 04/08/2004 13:40:12
grant beattie a écrit:
> On Wed, Apr 07, 2004 at 06:41:12PM +0200, Pierre Bourgin wrote:
>>I've just discovered that mod_perl in pkgsrc (www/ap-perl) depends on 
>>not on perl-5.8.3 :(
>>Unfortunatly, I need perl-5.8.3 on my solaris 8 box ... so I can't have 
>>since it requires perl-5.6.1 to build, and to be used: I try to build 
>>while perl-5.8.3 was already installed, and use it with perl-5.8.3 ...
>>does not work at all.
>>Does someone have comment about this or is working on ap-perl/perl-5.8.3 ?
> I've recently (yesterday) installed ap-perl 1.25 on Linux with perl
> 5.8.0 already installed, and while it did actually build, apache core
> dumps on startup.
> updating the package to 1.29 is fairly trivial, and that worked for my
> case so I'll commit the update shortly.

Yes please ! I've done the same under NetBSD-1.6ZL/i386 and Solaris 
and it works great for me (after upgraded to ap-perl-1.29).

I created PR pkg/25100 about this problem; could you close it (if you are
allowed to) once you upgraded pkgsrc ?


Pierre Bourgin