Subject: Re: mod_perl (ap-perl) and perl version
To: Pierre Bourgin <>
From: grant beattie <>
List: tech-pkg
Date: 04/08/2004 19:15:33
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Wed, Apr 07, 2004 at 06:41:12PM +0200, Pierre Bourgin wrote:

> Hello,
> I've just discovered that mod_perl in pkgsrc (www/ap-perl) depends on=20
> perl-5.6.1,
> not on perl-5.8.3 :(
> Unfortunatly, I need perl-5.8.3 on my solaris 8 box ... so I can't have=
> ap-perl,
> since it requires perl-5.6.1 to build, and to be used: I try to build=20
> ap-perl
> while perl-5.8.3 was already installed, and use it with perl-5.8.3 ...
> does not work at all.
> Does someone have comment about this or is working on ap-perl/perl-5.8.3 ?

I've recently (yesterday) installed ap-perl 1.25 on Linux with perl
5.8.0 already installed, and while it did actually build, apache core
dumps on startup.

updating the package to 1.29 is fairly trivial, and that worked for my
case so I'll commit the update shortly.


Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (NetBSD)