Subject: Re: graphics/libexif-gtk and gtkam and GTK_DISABLE_DEPRECATED failures
To: Berndt Josef Wulf <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/08/2004 01:31:44
On Wed, 7 Apr 2004, Berndt Josef Wulf wrote:

> Again, I'm sick and tired of needing to rebuild the whole system because the
> maintainer of a package decided to keep the BUILDING_DEPENDS variable in line
> with the current version of that particular package.

Another example of why bumping should be done is my just posted email
"dependencies wrong for expat and firefox-gtk2".

expat's buildlink files have depends for old version. So now I have a
bunch of: => not found

If it had been bumped I would not have this problem, because my binary
packages would force me to use a newer one.

I understand there is a new RECOMMENDED and IGNORE_RECOMMENDED settings,
but I am not sure how this helps. I need to find the docs for them.

But maybe it would be good to have dependencies in the files
for binary packages that are different than those used by users who just
use pkgsrc (and no binary packages).

   Jeremy C. Reed