Subject: Re: graphics/libexif-gtk and gtkam and GTK_DISABLE_DEPRECATED
To: Berndt Josef Wulf <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 04/07/2004 10:16:40
On Wed, 7 Apr 2004 08:28:12 +0930
Berndt Josef Wulf <> wrote:

> The problem here again is that the maintainer of the gtk packages insisted in 
> setting the BUILDLINK_DEPENDS.variable gtk2?= gtk2+>=2.4.0.

That was a must, given that the shared library included in the new version of
gtk2 changed its version number, meaning that if you 'make replace' gtk2, all
of your programs will stop working.

You can search the archives for an utility named pkg_hack, which installs new
versions of libraries but keeps the old .so files, so that applications not
rebuilt after the update keep working.


Julio M. Merino Vidal <>
The NetBSD Project -