Subject: Re: graphics/libexif-gtk and gtkam and GTK_DISABLE_DEPRECATED failures
To: Julio M. Merino Vidal <>
From: Berndt Josef Wulf <>
List: tech-pkg
Date: 04/07/2004 08:28:12
On Wed, 7 Apr 2004 02:56, Julio M. Merino Vidal wrote:
> On Tue, Apr 06, 2004 at 07:07:39PM +0200, Robert Lillack wrote:
> > Jeremy C. Reed wrote:
> > > What does this GTK_DISABLE_DEPRECATED mean?
> > >
> > > And is this related to new gtk+-2.4.0 update?
> >
> > Yes. This define (as the name implies) disables deprecated
> > features of your GTK lib. Looks like gtkam does *not* use
> > features which have been deprecated in 2.2 but it *does* use some
> > deprecated in 2.4. Now, call that "API & ABI compatible" again...
> > ;-/
> It's compatible as long as you don't use *_DISABLE_DEPRECATED, AFAICT.
> Maybe there is a newer version of gtkam and libexif that works with
> GTK+ 2.4 out of the box?  If not, I think removing those defines is ok
> (maybe some BUILDLINK_TRANSFORM magic can avoid manual patching? ;).

The same problem was noted after the recent pkgsrc gtk upgrade with ham/xlog 
that uses the _DISABLE_DEPRECATED_ compiler switch. I worked around it by 
removing this switch after which the package built fine. I was sort of hoping 
to see a new release of xlog, however, it may be necessary to add a patch in 
the interim.

The problem here again is that the maintainer of the gtk packages insisted in 
setting the BUILDLINK_DEPENDS.variable gtk2?= gtk2+>=2.4.0.

Most packages will still build with the older version of gtk2, so the above 
restriction isn't required and over the top causing a great many users 
headaches and pain, e.g. in my case I being unaware of the introduction of an 
updated version of gtk2 was naive enough to issue "make update" in 
pkgsrc/xlog which consequently deleted all gtk dependencies including all of 
the KDE3 environment. 

May I ask those who upgrade the BUILDLINK_DEPENDS variable for a particular 
package to give it throrough consideration before changing it, especially for 
those packages that have a major impact on pkgsrc? I seem to be spending more 
time in keeping my system up-to-date then doing actual development work. Most 
dependencies will happily built with the older version, if already installed, 
an there is no pressing need to force users to upgrade. Typical examples are 
ghostview, jpeg, tiff, gtk, qt3 to name a few.

Again, I'm sick and tired of needing to rebuild the whole system because the 
maintainer of a package decided to keep the BUILDING_DEPENDS variable in line 
with the current version of that particular package.

cheerio Berndt
Name	: Berndt Josef Wulf		| +++ With BSD on Packet Radio +++
E-Mail	: wulf at ping dot net dot au	|    tfkiss, tnt, dpbox, wampes
ICQ	: 18196098			|  VK5ABN, Nairne, South Australia
URL	:	| MBOX :
Sysinfo	: DEC Miata 500AU, NetBSD-1.6ZH	| BBS  : vk5abn.#lmr.#sa.aus.oc