Subject: Re: apache and audit-packages
To: Dick Davies <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/05/2004 09:13:56
On Sun, 4 Apr 2004, Dick Davies wrote:

> I'm still getting daily warnings about
> from audit-packages for apache-1.3.29...
> Is there a fix? I'm assuming this is the 'acls don't work on 64-bit platforms'
> error, but the URL given doesn't respond...

It comes up for me. Here are some other URLs for same:

It is "Arbitrary client-supplied strings can be written to the error log
which can allow exploits of certain terminal emulators."

The problem was fixed in the 2.0.49 release.

The 1.3.x branch was fixed on January 23, but I don't know what files.

I don't know if this is the entire fix:

If I have time today, I may make a patch based on above and put in pkgsrc.

(I have blind-carbon-copied this to tech-pkg.)

   Jeremy C. Reed