Subject: maybe wrong open-ended dependencies for perl packages
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/31/2004 20:13:39
The dependencies for many perl packages may be broken. For example, the
directory may be like lib/perl5/site_perl/5.6.1/

For example, I have p5-XML-SAX-0.12 installed.

The packing list shows:

 Package depends on: perl>=5.0

Another example is:

 rainier:/usr/pkgsrc/www/p5-HTML-Tagset$ make show-var VARNAME=DEPENDS

Is it okay to be open-ended like perl>=5.0 ??

Can I take a "5.6.1" p5 package and install when I have perl 5.8 installed

Maybe ../../lang/perl5/ or the buildlink?.mk files could set up a
DEPENDS that is more precise, like perl-5.6.* or perl-5.8.*.

Probably some other binary packages have same problems.

I have a pkg_update tool (extended pkg_add) which is used to overwrite
packages in place. And I am working on some scripts to update binary
packages (using a text file containing known packages metadata). My script
currently says I can update to perl-5.8.1, lynx- (which is
wrong) and lynx- Updating the perl in place may break many
other packages, but my pkg_update can't know because the @pkgdep is not
precise enough.

   Jeremy C. Reed