Subject: Re: Building sysutils/fam fails
To: None <>
From: Sylvester F <>
List: tech-pkg
Date: 03/27/2004 21:05:09
>I haven't used binutils from pkgsrc before, but it seems that pkgsrc
>doesn't set the path to the various binutils, so your PATH had to be
>tweaked. that should be fixable, but we're in a freeze right now..
>do you normally use pkgsrc binutils and is this the first problem
>you've had? or did this happen by mistake? :)

this is the first time i've had problems with ld.  actually i've not thought 
before what version
of ld i'm using, because it has always worked just fine :)

after i changed my path, i got the same error when compiling 
i tried with both lds(/usr/bin/ld & /usr/pkg/bin/ld) and it didn't work:

g++ -shared -nostdlib /usr/lib/crtbeginS.o  .libs/correct.o .libs/good.o 
.libs/hash.o .libs/lookup.o .libs/makedent.o .libs/tgood.o 
.libs/ispell_checker.o  -Wl,--rpath 
-Wl,--rpath -Wl,/mnt/uus/pkgsrc/textproc/enchant/work/.buildlink/lib 
-Wl,--rpath -Wl,/usr/pkg/lib -Wl,--rpath 
/mnt/uus/pkgsrc/textproc/enchant/work/.buildlink/lib/ -lintl 
-L/usr/pkg/gcc3/lib/gcc-lib/i386--netbsdelf/3.3.3/../../.. -lstdc++ -lm 
/usr/lib/crtendS.o  -Wl,-R/usr/pkg/gcc3/lib/gcc-lib/i386--netbsdelf/3.3.3 
-Wl,-R/usr/pkg/lib -Wl,--export-dynamic -Wl,-soname 
-Wl, -o .libs/
/usr/pkg/bin/ld: .libs/ undefined versioned symbol 
name std::time_get_c@@GLIBCPP_3.2
/usr/pkg/bin/ld: failed to set dynamic section sizes: Bad value
collect2: ld returned 1 exit status

The new MSN 8: smart spam protection and 2 months FREE*