Subject: Re: Samba with Heimdal: configure: error: libkrb5 is needed for
To: Christian Palomino <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/22/2004 09:30:19
On Mon, 22 Mar 2004, Christian Palomino wrote:

>  I get this message while building Samba, either from pkgsrc or
> compiling the sources from I have heimdal configured and it
> works fine, I get tickets, login works, etc... But I cannot manage to
> compile Samba with AD support. Does anyone know how can I tell the

So when you build from pkgsrc, do you use the SAMBA_WITH_ADS=yes option
(maybe in your /etc/mk.conf or the command line)?

Does the config* output tell you that ads was or was not configured?

> package to get libkrb5 from heimdal? I tried setting KRB5BASE to
> /usr/lib, where the libraries are, and usr/include/krb5, where the
> headers are.

That is done automatically for pkgsrc.

>  Do I have to recompile OpenLDAP to ensure it's done with kerberos support?

I don't know.

I have carbon copied this to tech-pkg. Consider replying to tech-pkg on

I removed tech-security from the Cc.

   Jeremy C. Reed