Subject: problems linking graphivs/plotutils-nox11
To: None <>
From: Georg Schwarz <>
List: tech-pkg
Date: 03/21/2004 15:48:13
Building graphics/plotutils-nox11 (on IRIX 5.3) I end up with:

/bin/ksh ../libtool --mode=link /usr/local/bin/g++  -O2
-I/usr/local/pkg/include -L/usr/local/pkg/lib
-Wl,-rpath,/usr/local/pkg/lib -o -rpath /usr/local/pkg/lib
-version-info 4:0:2 apioldcc.lo  mi_alloc.lo mi_api.lo mi_arc.lo
mi_canvas.lo  mi_fllarc.lo mi_fllrct.lo mi_fplycon.lo  mi_gc.lo
mi_ply.lo mi_plycon.lo mi_plygen.lo  mi_plypnt.lo mi_plyutil.lo
mi_spans.lo  mi_widelin.lo mi_zerarc.lo mi_zerolin.lo  mi_version.lo
g_affine.lo g_alabel.lo  g_alab_her.lo g_attrib.lo g_arc.lo g_bez.lo
g_box.lo g_circ.lo g_clipper.lo g_closepl.lo  g_colors.lo g_cntrlify.lo
g_dash.lo g_dash2.lo  g_defplot.lo g_defstate.lo g_ellipse.lo
g_endpath.lo g_error.lo g_erase.lo  g_flushpl.lo g_font.lo g_fontdb.lo
g_fontd2.lo  g_havecap.lo g_her_glyph.lo g_integer.lo  g_line.lo
g_linewidth.lo g_mark.lo g_matrix.lo  g_miscmi.lo g_move.lo g_openpl.lo
g_outbuf.lo  g_outfile.lo g_pagetype.lo g_param.lo  g_param2.lo
g_path.lo g_pentype.lo g_point.lo  g_relative.lo g_range.lo
g_retrieve.lo  g_savestate.lo g_space.lo g_subpaths.lo  g_vector.lo
g_version.lo g_write.lo  g_xmalloc.lo g_xstring.lo m_attribs.lo
m_closepl.lo m_defplot.lo m_emit.lo m_erase.lo  m_mark.lo m_openpl.lo
m_path.lo m_point.lo  m_text.lo b_closepl.lo b_defplot.lo b_erase.lo
b_openpl.lo b_path.lo b_point.lo t_attribs.lo  t_closepl.lo t_color.lo
t_color2.lo  t_defplot.lo t_erase.lo t_openpl.lo t_path.lo  t_point.lo
t_tek_md.lo t_tek_mv.lo  t_tek_vec.lo r_attribs.lo r_closepl.lo
r_color.lo r_defplot.lo r_erase.lo r_openpl.lo  r_path.lo r_point.lo
h_attribs.lo h_closepl.lo  h_color.lo h_defplot.lo h_erase.lo h_font.lo
h_openpl.lo h_path.lo h_point.lo h_text.lo  f_closepl.lo f_color.lo
f_color2.lo  f_defplot.lo f_erase.lo f_openpl.lo f_path.lo  f_point.lo
f_retrieve.lo f_text.lo  c_attribs.lo c_closepl.lo c_color.lo
c_defplot.lo c_emit.lo c_erase.lo c_mark.lo  c_openpl.lo c_path.lo
c_point.lo c_text.lo  p_closepl.lo p_color.lo p_color2.lo  p_defplot.lo
p_erase.lo p_openpl.lo p_path.lo  p_point.lo p_text.lo a_attribs.lo
a_color.lo  a_closepl.lo a_defplot.lo a_erase.lo  a_openpl.lo a_path.lo
a_point.lo a_text.lo  s_closepl.lo s_color.lo s_defplot.lo  s_erase.lo
s_openpl.lo s_path.lo s_point.lo  s_text.lo i_closepl.lo i_color.lo
i_defplot.lo  i_erase.lo i_openpl.lo i_path.lo i_point.lo  i_rle.lo
n_defplot.lo n_write.lo z_defplot.lo  z_write.lo -lpng -lz -lmx
awk: record `/usr/local/bin/g++ -...' has too many fields
 record number 1
libtool: link: unable to infer tagged configuration
libtool: link: specify a tag with `--tag'
*** Error code 1

bmake: stopped in
*** Error code 1

bmake: stopped in
*** Error code 1

Is is a libtool problem? Any ideas how to get around this?

Georg Schwarz     +49 177 8811442