Subject: Re: looking for Linux testers: libiconv package on glibc systems
To: Sebastian Prause <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/20/2004 08:11:08
On Sat, 20 Mar 2004, Sebastian Prause wrote:

> ===> libiconv-1.9.1nb1 is not needed for Linux; it is included in GNU
> libc.
> *** Error code 1
> [...]
> Now using either "bmake PREFER_NATIVE=iconv" or "bmake USE_GNU_ICONV=YES
> PREFER_NATIVE=iconv" makes the build succeed. (Using only "bmake
> USE_GNU_ICONV=YES" fails with above error message, too).

Did you remove the libiconv package first?

Because it should not need the PREFER_NATIVE=iconv set. It should do the
right thing without it.

> devel/glib2 works, too, so I guess libiconv it's not needed on Linux with
> glibc

Thank you, Sebastian, for trying this.

(I had set Reply-To and Mail-Follow-up-To in the hopes that the reply
wouldn't go to both lists. Please reply to tech-pkg@ only.)

   Jeremy C. Reed