Subject: Re: ImportError: No module named gconf
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/17/2004 20:03:03
On Tue, 16 Mar 2004, Jeremy C. Reed wrote:

> I am trying to build databases/gramps and I get
> checking Python bindings for GNOME... ok
> checking Python bindings for gconf... Traceback (most recent call last):
>   File "", line 17, in ?
>     import gnome.gconf
> ImportError: No module named gconf

Many hours later I solved this.

Well, I decided to comment out that problem code in the gramps configure
script. So I installed gramps and attempted to run it.

Traceback (most recent call last):
  File "/usr/share/gramps/", line 80, in ?
    import gramps_main
  File "/usr/share/gramps/", line 45, in ?
    import gnome.ui
ImportError: /usr/lib/ undefined symbol:

Yea! So now I finally had a real error to look at.

I didn't see that symbol defined in ORBit2. So I upgraded from
ORBit2-2.8.2 to ORBit2-2.8.3 but that didn't help. Then I update my
libbonobo-2.4.3 to libbonobo-2.4.3 (same version built from source). But
still no fix.

Then I saw a old file /usr/lib/ from September. So did:
 sudo rm /usr/lib/
 sudo ldconfig -v

And all was well.

And now that gconf python module works too.

I spent several hours on this since yesterday. It sure would have been
nice if I had some idea of what the real error message was. Once I
realized that it was  "undefined symbol: ORBit_c_stub_invoke" I had this
solved pretty quick.

I guess that I just didn't hit that problem with other software I had been
running since I started updating this system last week.

   Jeremy C. Reed

p.s. As for my other issue, I think the dependency_libs in the .la files
still need to be fixed.