Subject: ImportError: No module named gconf
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/16/2004 08:21:51
I am trying to build databases/gramps and I get

checking Python bindings for GNOME... ok
checking Python bindings for gconf... Traceback (most recent call last):
  File "", line 17, in ?
    import gnome.gconf
ImportError: No module named gconf
cat: conftest.out: No such file or directory
configure: error:
**** The python bindings for gconf (gnome-python2-gconf) could not be
*** Error code 1

The error is on "import gnome.gconf".

Something has changed in the buildlinking within the poast couple weeks or
something has changed with the gnome-related packages it uses. Because
this worked for me under Linux with LOCALBASE as /usr a couple weeks ago
fine. (I have been using my gramps packages under Linux for a couple
months now, until it stopped building lately.)

I am pretty sure this is related to my other emails about

This is what I tried next in mk/buildlink3/

@@ -675,7 +675,7 @@
 	-e "/^dependency_libs=/s,${DEPOTBASE}/[^${_BLNK_SEP}]*\(/[^${_BLNK_SEP}]*/lib[^/${_BLNK_SEP}]*\.la\),${BUILDLINK_DIR}\\1,g" \
 	-e "/^dependency_libs=/s,${X11BASE}\(/[^${_BLNK_SEP}]*/lib[^/${_BLNK_SEP}]*\.la\),${BUILDLINK_X11_DIR}\\1,g" \
 	-e "/^dependency_libs=/s,${LOCALBASE}\(/[^${_BLNK_SEP}]*/lib[^/${_BLNK_SEP}]*\.la\),${BUILDLINK_DIR}\\1,g" \
-	-e "/^dependency_libs=/s,-L/usr/lib[^/${_BLNK_SEP}]*[ 	]*,,g"	\
+	-e "/^dependency_libs=/s,-L/usr\(/lib[^/${_BLNK_SEP}]*[ 	]*\),-L${BUILDLINK_DIR}\\1,g"	\
 	-e "/^dependency_libs=/s,-L${X11BASE}/[^${_BLNK_SEP}]*[ 	]*,,g" \

   Jeremy C. Reed