Subject: Re: Cannot link editor Ted
To: Jonathan <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/16/2004 07:58:59
(I composed this yesterday, but mail server had broken dnsbl that rejected

On Tue, 16 Mar 2004, Jonathan wrote:

>         -lXp.6 = not found
>         -lXmu.6 = not found
>         -lXt.6 = not found
>         -lXext.6 = not found
>         -lSM.6 = not found
>         -lICE.6 = not found
>         -lX11.6 = not found

You may want to try building with:


which appears to be already done.

> I installed the 2.14 version that is in pkgsrc. When I run it I get the
> same error that I get when running the statically linked version, namely:
> notebook: {2} Ted
> Shared object "" not found

/usr/pkgsrc/editors/ted just built and installed fine for me under NetBSD
1.6.2. It does uses libXp:

         -lXp.6 => /usr/X11R6/lib/

What NetBSD version are you using?

Maybe you can get the configure and build logs saved and available via ftp
or http?

>  I am new to NetBSD but would like to see the next version of Ted (2.15)
> work well in my newly found OS. I think NetBSD is a wondeful UN*X OS. As
> I say I am testing Ted-2,15a7 in preparation for the April (hopefully)
> release.

Thank you for trying Ted under NetBSD. I have used Ted off and on for
around 5? years and I am glad there is continued development.

If you have your latest Ted source available, I'd be glad to test with
pkgsrc under NetBSD and Linux (using pkgsrc).

   Jeremy C. Reed