Subject: Re: gpatch?
To: grant beattie <>
From: MLH <>
List: tech-pkg
Date: 03/10/2004 17:01:07
> On Wed, Mar 10, 2004 at 01:07:58PM -0600, MLH wrote:
> > > Try specifying PATCH on mk.conf, don't you have patch in your system?
> > Ok. Actually I think using gpatch is a move in the right direction
> > because solaris' /bin/patch had problems last I tried to use it.
> > I was using the installed SUNWspro cc, but I think I'll install
> > the solaris gcc3 and try to build gpatch using that.
> I have no reason to believe there is a problem building GNU patch on
> Solaris with SunPro. because of the way the GNU patch dependency is
> handled now, any packages with patches will automatically gain a build
> dependency on devel/gpatch (if you didn't optionally install it from
> the 2nd CD).
> I blow away /usr/pkg and rebuild everything regularly, as well as run
> bulk builds with SunPro, and both would fail very early if GNU patch
> didn't build.

I had just done that- trashed /usr/pkg, rebuilt bootstrap-pkgsrc
and tried to build gmake, which required gcc3, which apparently
required gpatch but there was no built-in dependency, likely due
to the circular dependency observed.

> what was the problem building packages with SunPro, and what version
> do you have?

Only that I couldn't build devel/patch with it since devel/patch
indicates that it requires gcc3 to build.

cc: Sun WorkShop 6 update 1 C 5.2 2000/09/11

> the specific problem of building a compiler from pkgsrc before all
> necessary tools are available is a bootstrapping problem which we hope
> to address in the near future...

It looks like things are under control now, but I had to install
the solaris gcc3 package and build devel/patch first, then work on
gmake and gcc3 with it first. So far:

patch-2.5.4nb2      Patch files using diff output
gmake-3.80nb2       GNU version of 'make' utility
gcc3-c-3.3.3        GNU Compiler Collection, v3 - C compiler
gcc3-c++-3.3.3      GNU Compiler Collection, v3 - C++ compiler

> > but devel/gcc3 maybe can't use it?  Might be nice to document this
> > in the bootstrap-pkgsrc for Solaris so someone else trying to use
> > SUNWspro cc doesn't trip over it.
> Solaris' /bin/patch is not sufficient for pkgsrc use.

 From past experience, I was pretty sure that this was correct.