Subject: Re: dependencies not working? - pkgviews?
To: None <>
From: Hal Snyder <>
List: tech-pkg
Date: 03/09/2004 11:07:17
Steve Bellovin <> writes:

> While trying to rebuild certain packages -- libxml2 had a security
> advisory -- I've run into a couple of instances where packages
> didn't seem to pick up the proper dependencies, or didn't seem to
> notice that a package was already installed. Just now, for example,
> I'm rebuilding gtk2+ manually because abiword didn't find it. I've
> also had problems with pango, and with imlib not requiring
> x11-links. Has something changed? Am I doing something wrong? (I've
> simply used pkg_delete and 'make install' with no overrides or 'make
> reinstall'; I removed all work directories, have complete current
> pkgsrc, etc.)

Not sure if this is related, but we're seeing the same sort of thing
with pkgviews and Solaris as follows:

Per instructions at pkgsrc/mk/buildlink3/PKGVIEWS_UG, start with clean
install and build digest as first package - note there is a conflict
with digest as built by bootstrap-pkgsrc and the linkfarm warning not
seen in the UG sample output.

- fresh install of i386 Solaris 9
- install gcc3.3.2 sunfreeware package
- check out current bootstrap-pkgsrc and build it
- check out current pkgsrc (onto another host) and copy to /usr/pkgsrc
- create /etc/mk.conf

PKG_INSTALLATION_PREFS= pkgviews overwrite
PKG_DBDIR=      /var/db/pkg
LOCALBASE=      /usr/pkg
CC=             /usr/local/bin/gcc

- cd /usr/pkgsrc/pkgtools/digest && bmake build
- delete digest package so we can pkgviews build it
  pkg_delete digest
  bmake install
===> Registering installation for digest-20021220
===> Building views for digest-20021220
=> Performing package view clash check for digest-20021220 in standard view
=> Performing package view overwrite check for digest-20021220 in standard view
/usr/pkg/sbin/linkfarm: test: argument expected
=> Linking package into standard view

- cd /usr/pkgsrc/devel/patch && bmake install
digest-20021220     Message digest wrapper utility
patch-2.5.4nb2      Patch files using diff output

- want to build pkgsrc gcc3 asap, but this needs gmake, and so on down
  to devel/libtool-base, so start with that (btw what is the best way
  to see a tsort of dependencies of a package?)

  and here, system needs patch>=2.2, doesn't find it, tries to build
  it, etc.

work -> /usr/obj/pkg/devel/libtool-base/work
===> Extracting for libtool-base-1.5.2nb4
===> Required package patch>=2.2: NOT found
===> Verifying reinstall for ../../devel/patch
===> *** No /usr/pkgsrc/distfiles/pkg-vulnerabilities file found,
===> *** skipping vulnerability checks. To fix, install
===> *** the pkgsrc/security/audit-packages package and run
===> *** '/usr/pkg/sbin/download-vulnerability-list'.
===> Installing for patch-2.5.4nb2
===> patch-2.5.4nb2 is already installed - perhaps an older version?
*** If so, you may use either of:
***  - "pkg_delete patch-2.5.4nb2" and "/usr/pkg/bin/bmake reinstall" to upgrade properly
***  - "/usr/pkg/bin/bmake update" to rebuild the package and all of its dependencies
***  - "/usr/pkg/bin/bmake replace" to replace only the package without re-linking
***    dependencies, risking various problems.


Commenting out the PKG_INSTALLATION_PREFS setting in /etc/mk.conf
prevents the problem with patch.

I'm aware of the disclaimers regarding pkgviews - but wondered if it
was time to begin exploring it yet.