Subject: qt3-libs install errors
To: None <>
From: Joe Reed <>
List: tech-pkg
Date: 03/06/2004 10:35:23
related to my previous question (subject "libtool, qt3, pkgviews" 03/05/2004)  
i've attempted to install qt3-libs on a fresh system. (only libtool and 
digest installed)

the following error occurs during install

install -d -o root -g wheel -m 755 /usr/pkg/qt3/plugins
install -d -o root -g wheel -m 755 /usr/pkg/qt3/plugins/imageformats
libtool install -c -o root -g wheel -m 
444 /usr/build/pkgsrc/obj/x11/qt3-libs/work.bork/qt-x11-free-3.2.3/plugins/imageformats/ /usr/pkg/qt3/plugins/imageformats/
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require -mode=MODE be specified.
libtool: install: error: cannot install 
to a directory not ending in /usr/pkg/qt3/plugins/imageformats
*** Error code 1

this is confusing in that libtool is not correctly comparing the directories.

any idea?


Die, v.:
	To stop sinning suddenly.
		-- Elbert Hubbard