Subject: Re: AIX build failures and one bootstrap problem (with solution)
To: Peter Schmiedeskamp <>
From: grant beattie <>
List: tech-pkg
Date: 03/03/2004 19:29:24
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

On Sun, Feb 29, 2004 at 11:17:25PM -0800, Peter Schmiedeskamp wrote:

> First, I had one minor problem during the bootstrap
> process.  Namely, there appears to be a bug in the
> bootstrap shell script that prevents sed from being
> found.  When I ran the bootstrap initially, I noticed
> that it was trying to execute ./sed (which is a
> directory when you are in the directory containing the
> shell script bootstrap).  The first invokation of sed
> ofcourse failed.  I was able to get past this hicup by
> setting the environment variable "sedprog" to the
> location of sed on my machine.

hi Peter,

is/was "." in your $PATH? that could be the cause of this..

would you be able to send me the output of running
"sh -x ./bootstrap" on this system?

> checking for a sed that does not truncate output...
> (cached) /usr/pkg/bin/nbsed
> checking build system type... powerpc-ibm-aix5.1.0.0
> checking host system type... configure: error: /bin/sh
> ./config.sub --aix failed
> *** Error code 1

> Now, I also get the same error if I try to compile
> other programs such as patch.  Interestingly if I do a
> "bmake extract," I can go into the work directory and
> do a "./configure; make" with no problems.

this sounds like configure is being called with the wrong
arguments for some reason. you can get some debug output by running
eg. "bmake configure PKG_DEBUG_LEVEL=2" to see exactly what's going

what is the output of

> My guess is that support for AIX 5.1 may not be
> entirely complete (understandable as AIX isn't a
> supported platform).  If someone who understands the
> pkgsrc system better than I is interested in working
> with me, I'd love to try to get pkgsrc up to a useable
> state on AIX 5.1.

I can help debug things, but you'll be on your own to some extent, as
I don't have access to an AIX machine.


Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (NetBSD)