Subject: AIX build failures and one bootstrap problem (with solution)
To: None <>
From: Peter Schmiedeskamp <>
List: tech-pkg
Date: 02/29/2004 23:17:25
Hello, I've somehow ended up building more software
than I would like on AIX 5.1 so I'm turning to my
favorite package manager for help.  I've had a couple
of problems so far that I thought I'd report.

First, I had one minor problem during the bootstrap
process.  Namely, there appears to be a bug in the
bootstrap shell script that prevents sed from being
found.  When I ran the bootstrap initially, I noticed
that it was trying to execute ./sed (which is a
directory when you are in the directory containing the
shell script bootstrap).  The first invokation of sed
ofcourse failed.  I was able to get past this hicup by
setting the environment variable "sedprog" to the
location of sed on my machine.

After bootstrapping and downloading the newest pkgsrc
tarball, I attempted to build some software (zsh to be
specific).  It attempts to compile libtool-base as a
dependency and gets the following error:

checking for a sed that does not truncate output...
(cached) /usr/pkg/bin/nbsed
checking build system type... powerpc-ibm-aix5.1.0.0
checking host system type... configure: error: /bin/sh
./config.sub --aix failed
*** Error code 1

Now, I also get the same error if I try to compile
other programs such as patch.  Interestingly if I do a
"bmake extract," I can go into the work directory and
do a "./configure; make" with no problems.

My guess is that support for AIX 5.1 may not be
entirely complete (understandable as AIX isn't a
supported platform).  If someone who understands the
pkgsrc system better than I is interested in working
with me, I'd love to try to get pkgsrc up to a useable
state on AIX 5.1.


Do you Yahoo!?
Get better spam protection with Yahoo! Mail.