Subject: Problems building net/tcl-scotty on 1.6.2-i386
To: NetBSD tech-pkg Mailing List <>
From: Douglas Wade Needham <>
List: tech-pkg
Date: 02/22/2004 18:57:40
Greetings everyone,

Since the release of 1.6.2, I have been building a new repository from
which I will be using rdist to update most of my machines (i.e. those
not running current).  The machine on which I am doing these builds is
an AMD K7 with an install base of one of the earlier 1.6.2 RC release
(RC1) along with the packages I build for 1.6.1.  However, I do my
builds in a chroot'ed sandbox which was build off of the src and xsrc
obtained from on Feb 18 starting at 00:48ET using
the following command line:

    cvs -lq update -d -P -r netbsd-1-6-PATCH002

The builds of the base OS and X11 worked flawlessly.  However, since
then I have been trying to build my packages in my chroot'ed sandbox,
and I get errors when trying to build net/tcl-scotty.  The error
involves rpcgen failing to find the C preprocessor.  Several attempts
have yielded identical results, using a pkgsrc tree resulting from the
following three command lines:

    cvs -lq update -d -P -D "02/18/2004 00:00 EST"
    cvs -lq update -d -P -D "02/19/2004 00:00 EST"
    cvs -lq update -d -P -D "02/20/2004 00:00 EST"

As a result, I must conclude that this problem is not transitory.
Additionally, outside of a change to databases/db3/distinfo to fix the
checksum for one of the patches, changes to x11/xview-config to fix I
problem seen when compiling under current (detailed in a previous
message), and the addition of several new packages, my pkgsrc tree is
vanilla.  So I must conclude it is either a problem with the
net/tcl-scotty package or with the base OS.  However, I saw no changes
to this package which would account for it no longer building (built
fine for me on 1.6.1), and I found nothing really close, other than
some stuff related to PR22311, which dealt with mail/drac.  So to take
things one step further, I interactively chroot'ed into the sandbox
and was able to run rpcgen manually on these files.  Since my build
scripts do not define CPP and do builds of the packages on an
individual basis, I am starting to think my name is Alice, and that
things are definitely "curiouser and curiouser".  But this leaves me
with the following questions:

1) Has anyone else tried to build tcl-scotty under 1.6.2, possibly on
   the i386?
2) If so, did you see this error?
3) Is this yet another instance of the problem reported by PR22311?

For those interested in my sandbox environment or my additional
packages which have been ported or are in progress, please see my
cvsweb repository at the following URL:

For the latest build logs, they are quite large (32MB and 38MB
uncompressed, and 1136KB and 2400KB gziped for the OS/X11 and package
builds respectively).  If there is interest in them, please contact me
and I can provide you a URL to them.

- Doug

Douglas Wade Needham - KA8ZRT        UN*X Consultant & UW/BSD kernel programmer
Email:  cinnion @ ka8zrt . com
Disclaimer: My opinions are my own.  Since I don't want them, why
            should my employer, or anybody else for that matter!