Subject: pkgsrc failure ?
To: None <>
From: Florence HENRY <>
List: tech-pkg
Date: 02/19/2004 08:48:01

I encountered strange problems with the pkgsrc (updated by sup yesterday).
Several packages (libtool and libogg) seem to be installed serveral times
with different versions, and only one is in the /var/db/pkg (the older

The problem is that I cannot compile any package needing the new versions
of libtool or libogg. Example with xine-lib :

/usr/pkgsrc/multimedia/xine-lib# make
===> Checking for vulnerabilities in xine-lib-1rc0anb3
===> Required package libogg>=1.1: NOT found
===> Verifying reinstall for ../../audio/libogg
===> Checking for vulnerabilities in libogg-1.1
===> Installing for libogg-1.1
===>  libogg-1.1 is already installed.
*** Error code 1


One way to solve the problem should be to pkg_delete libogg-1.1 and let
xine-lib install it. But xine-lib also depends on flac-1.1.0nb1 that needs
libogg-1.1 too. The probleme occurs then at the building of flac-1.1.0nb1.

There must be something wrong on my system (I have other machines that do
not have this problem), but what ???

thanks for any tip...

ps : my machine is an i386, running -current 1.6ZE

Florence HENRY