Subject: Trouble with pthread
To: None <>
From: Sylvester F <>
List: tech-pkg
Date: 02/14/2004 07:16:56

I'm trying to build gtk2, but it stops on configure:

checking for GLIB - version >= 2.1.4... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for 
*** exact error that occured. This usually means GLIB is incorrectly 
configure: error:
*** GLIB 2.1.4 or better is required. The latest version of
*** GLIB is always available from
*** Error code 1

When I look at the config.log, it says the following:

configure:21113: gcc -o conftest -O2 -I/usr/pkg/include -I/usr/include 
-I/usr/X11R6/include -Wall -D_REENTRANT -I/usr/pkg/include/glib/glib-2.0 
lude     -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/freetype2 
-I/usr/X11R6/include   -L/us
-Wl,-R/usr/pkg/gcc3/lib/gcc-lib/i386--netbsdelf/3.3.2 -
L/usr/pkg/gcc3/lib -Wl,-R/usr/pkg/gcc3/lib -L/usr/pkg/lib -Wl,-R/usr/pkg/lib 
-L/usr/lib -Wl,-R/usr/l
ib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib conftest.c -lintl  
-Wl,-R/usr/pkg/lib -Wl,--export-dynamic
-L/usr/pkg/lib -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lpthread 
-lglib-2.0 -liconv -lm   >&5
/usr/pkg/bin/ld: cannot find -lpthread
collect2: ld returned 1 exit status

It seems that it can't find the pthread library, but I DO have pth-2.0.0 
installed, and ls /usr/pkg/lib/libpthread* says:


Any ideas what might be the problem?
I run NetBSD 1.6.1 on i386.

Sylvester F

STOP MORE SPAM with the new MSN 8 and get 2 months FREE*