Subject: Re: anyone use lang/gcc3-c and lang/gcc3-c++ as only compilers?
To: Johnny C. Lam <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 02/03/2004 12:23:12
On Tue, 3 Feb 2004, Johnny C. Lam wrote:

>  If you
> are requiring all of pkgsrc to be built using gcc3-*, then I recommend
> adding 'GCC_REQD+= 3.3' to your /etc/mk.conf.

Can we make it so that is not needed? Can't it just check the version that
is installed and use if good enough?

(Especially since the behaviour worked before.)

For the past 12 months or so, I have used just gcc3 (and then gcc3-c and
gcc3-c++) from pkgsrc as my only compiler on a few systems. And it did the
right thing (plus I made symlinks to $LOCALBASE/bin as needed). The only
time it was a problem was when c++ (CXX) was missing (such as removed
gcc3-c++ package).

Now, when building archivers/zip I get:
===> Required package gcc>=2.8.0: NOT found

But that is not good. I have:

$ gcc -dumpversion
$ command -v gcc
$ ls -ld `command -v gcc`
lrwxrwxrwx    1 root     root           17 Sep 23 16:30 /usr/bin/gcc -> /usr/gcc3/bin/gcc
$ pkg_info -L gcc3-c-3.3.2 | grep /usr/gcc3/bin/gcc

===> Verifying reinstall for ../../lang/gcc
===> Checking for vulnerabilities in gcc-2.95.3nb5

archivers/zip built fine before using gcc version 3.

I know it is minor, but I'd prefer to not have to manually (and
continually) keep GCC_REQD up-to-date on all mk.conf files.

   Jeremy C. Reed