Subject: Re: Samba/LISa Problem in KDE-3.1.5
To: Stephen Nelson <>
From: Ian Zagorskih <>
List: tech-pkg
Date: 02/03/2004 17:12:27
Well, I just can say that i had same problem with NetBSD-1.6.1 + KDE 3.1.2,
3.1.3 and 3.1.4.

After i upgrader KDE to the latest released v3.1.5 it runs fine on
NetBSD-1.6.1-stable/i386 and copying files over SMB network works fine
regardless to file size (i tried up to 640Mb). SMB servers are both Windows
2000 SP3 and NetBSD 1.6.1-stable running Samba 2.2.8a.

One thing I found is that data transfer speed is relatively slow - no more
then 2.4 Mb/s on full duplex 100MBit Etherner.
Same time I have stable 8..9 Mb/s when downloading files over NFS or SMB
from the same NetBSD server. I guess the bottleneck is hidden somewhere in
KDE/SMB backend.

Just a little fact, not sure if it helps you alot :)

ps: KDE 3.1.5 was built from official pkgsrc ~1 month ago or so.

// wbr

----- Original Message -----
From: "Stephen Nelson" <>
To: <>
Sent: Wednesday, February 04, 2004 4:57 AM
Subject: Samba/LISa Problem in KDE-3.1.5

> I am having problems copying files from samba shares using konqueror: when
> copy or move a file from a samba share, a dialog box pops up showing a
> bar, but after copying about 10% of the file, it stops, and the speed
> indicator shows 'stalled' after a few seconds. Nothing happens after this,
> but the file I tried to copy appears in the desired location with the name
> foo.part
> If I remove the .part, often the file is complete and usable, which
> to me that the copy completed, but much faster than expected. The strange
> thing is that the file, though complete, is reported by kde to have a much
> smaller file size than it should.
> I am using kde-3.1.5nb1 (or whatever the most recent verion is - I built
it 2
> days ago), samba-3.0.1nb1, from pkgsrc. I didn't have this problem with
> kde-3.1.4
> Has anyone else had this problem
> Stephen