Subject: automake doesn't build on 1.6.x
To: None <>
From: Bang Jun-Young <>
List: tech-pkg
Date: 02/01/2004 14:13:44

I got the following error when I tried to build automake on a freshly
installed 1.6.2 RC4 system:

Making all in doc
Updating ./version.texi
restore=: &&  backupdir=".am$$" &&  am__cwd=`pwd` && cd . &&  rm -rf $backupdir && mkdir $backupdir &&  for f in ./ ./[0-9] ./[0-9][0-9] ./automake.i[0-9] ./automake.i[0-9][0-9]; do  if test -f $f; then  mv $f $backupdir;  restore=mv;  fi;  done;  cd "$am__cwd";  if /home/junyoung/pkgsrc/devel/automake/work/.tools/bin/makeinfo  --no-split -I .  -o ./ ./automake.texi;  then  rc=0;  cd .;  else  rc=$?;  cd . &&  $restore $backupdir/* `echo "././" | sed 's|[^/]*$||'`;  fi;  rm -rf $backupdir;  exit $rc
./automake.texi:10: Unknown command `copying'.
./automake.texi:33: Unmatched `@end'.
./automake.texi:83: Unknown command `insertcopying'.
makeinfo: Removing output file `./' due to errors; use --force to preserve.
*** Error code 2

This is not reproducable on -current, so I worked around it by copying
makeinfo(1) from -current to 1.6.x. Does that mean texinfo should be
pulled up to netbsd-1-6 branch? Since we're expecting release of 1.6.2
real soon now, that might be too late...