Subject: Re: Has no-one noticed this? (Re: can lang/gcc3 compile 64bit?)
To: None <>
From: Charlie Allom <>
List: tech-pkg
Date: 01/21/2004 22:10:07
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset=US-ASCII; format=flowed

On 18/01/2004, at 11:13 PM, Charlie Allom wrote:

> On 18/01/2004, at 11:25 AM, Charlie Allom wrote:
>> I am using lang/gcc3 on my Solaris 9 box as the only compiler, and 
>> for things in pkgsrc all is going well. But I am trying to compile 
>> ipfilter and it complains I cannot make 64bit programs...
> bugger, 3.3.2 from sunfreeware works. As does 3.3 sunfreeware. What is 
> wrong? :)

OK I found this:

After tipped off that gcc -E worked on no input :P so the preprocessor 
is ok.. perhaps, but the linker is not.

So I put this into lang/gcc3/Makefile:
(no gnu binutils please)
	#.if defined(USE_BINUTILS) && ${USE_BINUTILS} == "YES"
	#DEPENDS=       binutils>=
	#.  include "../../devel/binutils/"
(use the solaris ld and as, thanks.)
	.  if ${OPSYS} == "SunOS"
	CONFIGURE_ARGS+=    --enable-shared --with-as=/usr/ccs/bin/as \
      	                --with-ld=/usr/ccs/bin/ld --disable-nls
	.  else

gcc now says that it's compiled like I asked.. when I query it with -v, 
but I still get no 64bit goodness.

-- - Melbourne, Australia
  PGP: 0x14AA7941 || finger

content-type: application/pgp-signature; x-mac-type=70674453;
content-description: This is a digitally signed message part
content-disposition: inline; filename=PGP.sig
content-transfer-encoding: 7bit

Version: GnuPG v1.2.3 (Darwin)