Subject: openoffice-linux testers needed
To: None <>
From: Michael Rauch <>
List: tech-pkg
Date: 01/20/2004 10:05:24

I've created an updated version of the openoffice-linux package.
Under -current everything is fine, but if I try it under my 1.6.2_RC3 test
installation (same hardware), the install program fails. 
As there have been reports of people using it successfully under 1.6*, I'm
looking for people testing the package under 1.6*, so one can maybe narrow
down the error and find a workaround. I've tried out various things but so
far without any success.

A tarball which will extract into misc/openoffice-linux110/ is at

Some more details on the failure:
The message on the screen is "Couldn't open registry
file:///usr/pkg/OpenOffice.org1.1.0/program/services.rdb for reading"
The install program doesn't abort on that error, so you have to look for it
in the output. But one can find out quite easily that it has happened, as
the pkgsrc framework will complain that the PLIST is incorrect. ktrace
doesn't show anything suspicious, open() on the file succeeds. 
Using a -current kernel with 1.6.2 userland works fine, btw.