Subject: Re: problems installing/running mozilla
To: None <,>
From: Thomas Klausner <>
List: tech-pkg
Date: 01/20/2004 10:01:00
On Tue, Jan 20, 2004 at 09:55:18AM +0100, Michael Rauch wrote:
> > Since 1.5.1 works but 1.5.1nb1 doesn't, could it have something
> > to do with the added Xinerama support?
> I think so. libXinerama is only available as a static lib
> (/usr/X11R6/lib/libXinerama.a), which is compiled without -fPIC. Linking
> such a static library into a shared one ( won't work in
> general, but result in the error in the first quoted line.  
> One exception to this general rule is i386, where there's no real difference
> between code compiled with and without -fPIC, so, although wrong, it just
> happens to work there.

Ok, so the mozilla package needs to check for the shared libXinerama too,
not only for the header file.

I'll take a look at it, thanks for the hint.