Subject: Re: CVS commit: pkgsrc/devel/apr
To: None <,>
From: John Klos <>
List: tech-pkg
Date: 01/16/2004 04:31:29
> > > db4, a new dependency for apr, is broken (at least on ppc). Revert
> > > back to not needing db4 until it is fixed.

> > Does this change break subversion ?

> Yes, it does.  I will make the db4 dependency optional, defaulting to
> YES except on ppc.  If it is NO, apr will declare a CONFLICT with
> subversion-base.

What about m68k, VAX, and other slow architectures? Would you have any
objection to db4 being a dependency if it's already installed, and having
subversion install db4 before starting on apr?

John Klos