Subject: re: IceWM 1.2.7 execution problem (iconv not up-to-date ?)
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 01/06/2004 12:19:15

>         IceWM: Iconv doesn't supply (sufficient) 646 to unicode
> converters.

> Does anyone else seen the same issue ?

I have same problem today. This is on a new install of NetBSD/i386
1.6.2_RC3 with XFree86 Version 4.3.0 installed from

I have:

libiconv-1.9.1nb1   Character set conversion library
icewm-gnome-1.2.13nb1 Small, fast and light-weight window manager (GNOME version)

The error message is from the IceWM - C++ wrapper for locale/unicode
conversion file src/

A similar Red Hat posting said "Your system is too old." And another said
"too new". The postings said "it is ok disabling i18n."

pkgsrc/wm/icewm* is built with:
.if ${OPSYS} == "NetBSD"
CONFIGURE_ARGS+= --with-unicode-set=utf-32

Anyone else have this problem?

   Jeremy C. Reed