Subject: Re: inflation of PKGREVISION bumps [was Re: CVS commit: pkgsrc]
To: Rene Hexel <>
From: Berndt Josef Wulf <>
List: tech-pkg
Date: 01/04/2004 21:22:43
Hash: SHA1

On Sun, 4 Jan 2004 04:43 pm, Rene Hexel wrote:
> On 04/01/2004, at 2:39 PM, Michal Pasternak wrote:
> > changes). How can I know, what versions it will be incompatible with
> > in the
> > *future* ?
>    I'm not talking about the future.  I'm talking about the past.
>    If you update, e.g., libtiff to 3.6.1, you know that it's
> incompatible with 3.5.5 or lower.  Therefore binary packages
> that depend on libtiff that were compiled against 3.5.5 won't
> link against libtiff-3.6.1 (because it has an
> INCOMPATIBLE_WITH<=3D3.5.5 entry).
> > How would INCOMPATIBLE_WITH solve the problem Jeremy had?
>    See above.  If libtiff-3.6.1 has an INCOMPATIBLE_WITH
> entry for lower versions of libtiff, binaries compiled
> against these older versions would no longer install
> with a newer libtiff installed.

Another problem that I see is that package maintainer are too keenly settin=
BUILDLINK_DEPENDS.xxxx in the files to the current revision=20
level, although, applications  may not necessarily require it if backward=20
compatibility is ensured..

cheerio Berndt
=2D --=20
Name	: Berndt Josef Wulf		| +++ With BSD on Packet Radio +++
E-Mail	: wulf at ping dot net dot au	|    tfkiss, tnt, dpbox, wampes
ICQ	: 18196098			|  VK5ABN, Nairne, South Australia=20
URL	:	| MBOX :
Sysinfo	: DEC Miata 500AU, NetBSD-1.6ZF	| BBS  : vk5abn.#lmr.#sa.aus.oc=20
Version: GnuPG v1.2.3 (NetBSD)