Subject: Re: USE_SASL is too general?
To: Jonathan Perkin <>
From: Daniel Eggert <>
List: tech-pkg
Date: 12/30/2003 20:52:45
On Tuesday, December 30, 2003 7:48 PM, Jonathan Perkin wrote:

> * On 2003-12-30 at 18:16 GMT, Daniel Eggert wrote:
> > > So then why do the variables _need_ to be per-package?  I
> > > actually like being able to say USE_{SOMETHING} and know it
> > > means "if a package has support for {SOMETHING} I want to
> > > compile it in..."
> > 
> > > How difficult would it be to offer the decision making logic
> > > behind some kind of construct to allow simple inclusion or
> > > exclusion lists in mk.conf?
> > 
> > Well, a simple thing would be to use _USE_ variables (such as
> > POSTFIX_USE_SASL) instead of general USE_ (e.g. USE_SASL), but
> > this would of course create a vast amount of _USE_ variables.
> Something I keep on meaning to implement but never get around to it
> is e.g:
> USE_SSL+= mail/teapop chat/irssi

I like this. Looks very elegant.
> style variables for mk.conf which should cover the above cases.  I
> don't really like the way is currently quite
> ad-hoc - it'd be great to present the user with a heavily reduced
> set of USE_FEATURE+= knobs which they can turn on for specific
> packages, and which would clean up our Makefiles considerably
> (taking the SSL as an example, it would alone remove 8 individual
> <PKG>_USE_SSL variables, which are by no means the only ones which
> *could* have such a variable.)
> No code yet though, so comments would be great so that we can get
> this stuff standardised.

Yes, it certainly would clean up the variable name space.