Subject: VTunD not doing anything
To: None <>
From: Mirko Thiesen <thiesi@ReLink.NetWorkXXIII.Sytes.NET>
List: tech-pkg
Date: 12/29/2003 20:24:15
Hi there,

I recently updated my gateway box from 1.5_ALPHA to 1.6.2_RC2 (i386 port).
Updating itself worked fine, I had no problems compiling a new kernel and
building a new userland (which I did using build).

After booting the new kernel I decided to update the packages installed on
this system. I hadn't done any package updates (except absolutely critical
ones) for about one year, so I thought almost every package installed
would be out of date and could thus be updated with pkg_chk. Indeed,
pkg_chk did a good job, updating most packages, failing to build only very
few. I reinstalled them manually (make update) afterwards.

Now everything works - except VTunD (vtun-2.6nb3). It did compile and
install sucessfully, however, it simply does not do anything. The tun
device interfaces don't come up automatically after rebooting (after being
created at some stage of the boot process). If I "ifconfig tunX up" them
manually, nothing happens.

"ps" confirms the vtun daemon is running:

(20:01:13) root@ReLink [/usr/pkgsrc] # ps -ax | grep tun
  224 ??  IWs    0:00.00 vtund: waiting for connections on port 4900

This is what syslog says:

Dec 29 19:59:59 ReLink /netbsd: in6_ifattach: tun0 is not multicast
capable, IPv6 not enabled

In fact, this is exactly the same syslog said when it worked. That's
everything I can say about this problem. I rebuilt VTunD and its
dependencies -- it did not change anything. It seems that VTunD does not
"see" the incoming connection, but it is bound to the right interface.

"lsof" says this:

(20:18:22) root@ReLink [/usr/pkgsrc/sysutils/lsof] # lsof | grep tun
vtund       224     root    4u  IPv4 0xc0ca7b44        0t0     TCP *:4900

I don't have any ideas on how to proceed. Perhaps there is somebody out
there who can help me ... I'd appreciate any hints!

Thanks in advance for looking at this!

Bye, K&K,

PS: I'm not quite sure whether my problem really belongs to tech-pkg or
not. In fact, it seems the problem is more on the operating system's side
than on VTunD's. But then, VTunD is the *only* package (of 280 installed)
that did not "survive" the update. That's why I post to this list.
thiesi@NetWork23.Sytes.NET ---- NetBSD: Power to the people!
Tel.: ++49-(0)171-416 05 09 -- Fax: ++49-(0)171-134 16 05 09
Mirko Thiesen, P.O. Box 26 03 54, D-13413 Berlin, W. Germany
             "We're with you all the way, mostly"