Subject: libtool(?) problem with -current
To: None <>
From: Ossi Herrala <>
List: tech-pkg
Date: 12/21/2003 15:26:56
Hello list

I have been getting the following with many packages for like week now and
because of that I can't upgrade my installed packages. I get same errors
with devel/subversion and few more packages trying to use libz(?).

[oherrala@txpo:/usr/pkgsrc/textproc/libxml2]% make      
===> Checking for vulnerabilities in libxml2-2.6.2
=> Checksum OK for libxml2-2.6.2.tar.bz2.
work.txpo -> /usr/tmp/pkgsrc-work/textproc/libxml2/work.txpo
===> Extracting for libxml2-2.6.2
===> Required installed package xmlcatmgr>=0.2: xmlcatmgr-1.1 found
===> Required installed package libtool-base>=1.4.20010614nb11: libtool-base-1.4.20010614nb18 found
===> Required installed package gmake>=3.78: gmake-3.80nb2 found
===> Patching for libxml2-2.6.2
===> Applying pkgsrc patches for libxml2-2.6.2
===> Overriding tools for libxml2-2.6.2
===> Buildlinking for libxml2-2.6.2
libtool: compile: specify a tag with `--tag'
libtool: link: `nonempty.lo' is not a valid libtool object
libtool: install: `' is not a valid libtool archive
Try `libtool --help --mode=install' for more information.
sed: /usr/tmp/pkgsrc-work/textproc/libxml2/work.txpo/.buildlink/.tmp/inst/ No such file or directory
*** Error code 1

make: stopped in /u1/NetBSD/pkgsrc/textproc/libxml2
*** Error code 1

make: stopped in /usr/pkgsrc/textproc/libxml2

The system is:

[oherrala@txpo:~]% uname -mrsv
NetBSD 1.6ZG NetBSD 1.6ZG (GENERIC) #0: Sat Dec 13 23:04:11 EET 2003  

Any ideas?

Ossi Herrala, OH8HUB
PGP key ID:  0x78CD0337
Fingerprint: D343 F9C4 C739 DFFF F619  6170 8D28 8189 78CD 0337