Subject: Re: minimum slackware package requirement
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 12/17/2003 23:35:21
Just commenting on packages I have or are in pkgsrc or pkgsrc-wip and
packages I need.

On Thu, 18 Dec 2003, Juan RP wrote:

> > n52:~> ls /var/adm/packages/
> > aaa_base-9.1.0-noarch-1        logrotate-3.6.8-i486-1

Don't know aaa_base. I need a logrotate (or rotatelogs) packaged.

> > bash-2.05b-i486-3              m4-1.4-i386-2
> > bc-1.06-i386-2                 make-3.80-i386-1

Have all those.

> > bin-8.5.0-i386-1               man-1.5l-i386-1

Don't know bin. I have man-db packaged.

> > binutils-    man-pages-1.60-noarch-1

We have binutils. I need man-pages packaged which is a variety of
miscellaneous man pages for Linux (like fifo.4, hosts.5, hier.7,
tzselect.8, etc.)

> > bison-1.35-i386-1              module-init-tools-0.9.14-i486-2

We have bison. I don't know module-init-tools.

> > byacc-1.9-i386-1               ncurses-5.3-i386-1
> > bzip2-1.0.2-i386-4             ntp-4.1.2-i486-2
> > coreutils-5.0-i486-4           pkgtools-9.1.0-i486-4

Have all above (with pkgtools equivalent).

> > cxxlibs-5.1.0-i486-1           portmap-5.0-i486-1

cxxlibs as separate package woudl be nice. I have portmap.

> > dcron-2.3.3-i386-4             procps-2.0.16-i486-2

I have vixie-cron instead. I have procps.

> > devfsd-1.3.25-i386-2           readline-4.3-i486-3

I need devfsd. We have readline.

> > devs-2.3.1-noarch-18           reiserfsprogs-3.6.11-i486-1

I don't know devs. I need reiserfsprogs done. I do have xfsprogs which
needs to be imported to pkgsrc-wip.

> > diffutils-2.8.1-i386-1         sed-3.02-i486-1
> > e2fsprogs-1.34-i486-1          shadow-4.0.3-i486-8

I have all these. (I imported shadow recently to pkgsrc-wip.)

> > elflibs-9.1.0-i486-2           slocate-2.7-i486-2

I don't know elflibs. We have updatdb/locate in findutils.

> > etc-5.1-noarch-5               smartmontools-5.1_18-i486-1

I don't have an etc package yet (but most or everyting should be in other
packages). I don't have smartmontools.

> > findutils-4.1.7-i386-1         sysklogd-1.4.1-i486-8

We have those.

> > flex-2.5.4a-i486-2             syslinux-2.06-i386-1

We have flex. I don't have syslinux.

> > gawk-3.1.3-i486-1              sysvinit-2.84-i486-36
> > gcc-3.2.3-i486-2               tar-1.13.25-i386-1
> > gcc-g++-3.2.3-i486-1           tcpdump-3.7.2-i386-1
> > gdb-5.3-i386-1                 tcpip-0.17-i486-24

We have all these except tcpip. (I don't know tcpip.)

> > gettext-0.11.5-i386-1          traceroute-1.4a12-i386-2
> > glibc-2.3.2-i486-1             ttf-bitstream-vera-1.10-noarch-2

I have not imported my glibc yet to pkgsrc-wip. We have rest (if you
include net/traceroute-as). Maybe I need another traceroute package. (How
did I forget that?)

> > glibc-solibs-2.3.2-i486-1      utempter-0.5.2-i486-2
> > glibc-zoneinfo-2.3.2-noarch-1  util-linux-2.12-i486-1

I don't know utempter. My (not imported) glibc is one package, probably
should split up. I also have util-linux in pkgsrc-wip.

> > grep-2.5-i386-2                xfree86-4.3.0-i486-5
> > groff-1.17.2-i386-3            xfree86-devel-4.3.0-i486-3
> > gzip-1.3.3-i386-2              xfree86-docs-4.3.0-noarch-2
> > iptables-1.2.8-i486-1          xfree86-fonts-misc-4.3.0-noarch-2
> > kbd-1.08-i386-2                xfree86-fonts-scale-4.3.0-noarch-2
> > lilo-           yptools-2.8-i486-3

Have all these too. I need to import iptables to pkgsrc-wip. I recently
imported to pkgsrc-wip: yp-tools, ypbind-mt, and ypserv.

Oh ya ... I also have linux-kernel in my pkgsrc (need to import to
pokgsrc-wip). I also have a few others, including openoffice (for linux
build from source).

> These are too many packages installed IMHO, you can get XFree86* from
> pkgsrc-wip, and bitstream-vera, etc...

Just to add to that comment too -- see above.

   Jeremy C. Reed