Subject: Re: kdebase3 fails to build
To: Bang Jun-Young <>
From: Joachim Thiemann <>
List: tech-pkg
Date: 12/11/2003 14:12:04
On Tue, 2003-12-09 at 12:20, Bang Jun-Young wrote:
> On Thu, Dec 04, 2003 at 04:41:29PM -0500, Joachim Thiemann wrote:
> > Hello!  I am having trouble building x11/kdebase3 on i386/1.6ZF:
> > [...]
> > Looking into /home/pkgsrc/x11/kdebase3/work/.buildlink/lib, I see 
> >, but not libkdecore.a (or .so*)
> > 
> > I already tried rm -rf and reget of pkgsrc, and I removed all packages from
> > MesaLib on down.... help! (please?)
> I just saw the same problem and fixed it by
> $ ln -s /usr/pkg/lib/libkdecore.a liblibkdecore.a
> in kdebase3/work/.buildlink/lib.
> After that, the build went on for minutes, but this time g++ spitted
> off an error I just don't understand. My machine is screwed. :-(
> Jun-Young

Yes, that's how I tried fixing it at first, too.  Anyways, I did some
further digging and found that libkdecore.a is build by kdelibs3 and
placed into /usr/X11R6/lib.  It is NOT supposed to be built: instead
(according to the PLIST) and friends are supposed to be
built, but didn't because of a missing library (Xinreama?).  (It appears
that if the linking fails, a static link library is created instead of a
dynamic one)  (If you check the install of kdelibs with pkg_admin, it'll
tell you about the missing  So the first thing is to make
sure kdelibs3 installs completely.

Unfortunately I am not in a situation right now where I can do anything
- I tried to fix things by building new xfree (xsrc) then an update,
then...  well, let's just say my system is now sporked in a major way
and I can't even boot NetBSD right now ("not a bootxx image"?) but that
discussion belongs on another list.