Subject: Re: kdebase3 fails to build
To: Joachim Thiemann <>
From: Bang Jun-Young <>
List: tech-pkg
Date: 12/10/2003 02:20:06
On Thu, Dec 04, 2003 at 04:41:29PM -0500, Joachim Thiemann wrote:
> Hello!  I am having trouble building x11/kdebase3 on i386/1.6ZF:
> gmake[3]: Entering directory `/home/pkgsrc/x11/kdebase3/work/kdebase-3.1.4/libkonq'
> /bin/sh ../libtool --silent --mode=link --tag=CXX c++  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium4 -DGLX_GLXEXT_LEGACY -I/usr/pkg/include -I/usr/X11R6/include -march=pentium4 -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -D_GNU_SOURCE   -L/usr/pkg/qt3/lib -Wl,-R/usr/pkg/qt3/lib -Wl,-R/usr/lib  -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib -o konq_sound_la_closure.lo -L/usr/X11R6/lib -L/usr/pkg/lib  -L/usr/pkg/qt3/lib -Wl,-R/usr/pkg/qt3/lib -Wl,-R/usr/lib  -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib -module -avoid-version -module -no-undefined   konq_sound.lo -lsoundserver_idl -lartskde -Wl,-E
> c++: /home/pkgsrc/x11/kdebase3/work/.buildlink/lib/libkdecore.a: No such file or directory
> gmake[3]: *** [] Error 1
> gmake[3]: Leaving directory `/home/pkgsrc/x11/kdebase3/work/kdebase-3.1.4/libkonq'
> gmake[2]: *** [all-recursive] Error 1
> gmake[2]: Leaving directory `/home/pkgsrc/x11/kdebase3/work/kdebase-3.1.4/libkonq'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/home/pkgsrc/x11/kdebase3/work/kdebase-3.1.4'
> gmake: *** [all] Error 2
> *** Error code 2
> Stop.
> make: stopped in /home/pkgsrc/x11/kdebase3
> *** Error code 1
> Stop.
> make: stopped in /home/pkgsrc/x11/kdebase3
> Looking into /home/pkgsrc/x11/kdebase3/work/.buildlink/lib, I see 
>, but not libkdecore.a (or .so*)
> I already tried rm -rf and reget of pkgsrc, and I removed all packages from
> MesaLib on down.... help! (please?)

I just saw the same problem and fixed it by

$ ln -s /usr/pkg/lib/libkdecore.a liblibkdecore.a

in kdebase3/work/.buildlink/lib.

After that, the build went on for minutes, but this time g++ spitted
off an error I just don't understand. My machine is screwed. :-(


Bang Jun-Young <>