Subject: Re: amanda-dev-client broken on 64bit sparc platforms
To: Gert Doering <>
From: Gert Doering <>
List: tech-pkg
Date: 12/06/2003 15:06:13

On Fri, Dec 05, 2003 at 02:34:05PM +0100, Gert Doering wrote:
> On Fri, Dec 05, 2003 at 08:09:06AM -0500, Greg Troxel wrote:
> > You really should report this/send a patch to the amanda folks.
> Will do.  But on the other hand, the amanda-dev-* pkg is a fairly old
> version anyway (2.4.3b3, while lists 2.4.4p1 as "the latest
> stable version"), so the pkg needs some work in any case.

Following up on myself again.

I have checked the current stable amanda version (2.4.4p1) and the current
development snapshot (2.5.0-20031202), and both have the fixes, using
"socklen_t" in both places.

So IMHO what really needs doing is upgrade the NetBSD pkgs to a more 
recent version - "amanda" should be 2.4.4p1, and "amanda-dev" should 
be "2.5.*".

What's the correct procedure to get this done?  I don't claim to
understand the pkgsrc structure (and have no write access anyway), but
there is no current maintainer listed either...

USENET is *not* the non-clickable part of WWW!
Gert Doering - Munich, Germany                   
fax: +49-89-35655025