Subject: perl5 ... ld: cannot find -lgdbm ... You have a BIG problem.
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 12/04/2003 18:55:01
Building perl5 worked for me under BSD/OS in October.

Now it does:

  I used the command:

          cc -o try -O2 -I/usr/pkg/include -fno-strict-aliasing
  -I/usr/pkg/include -Wl,-R/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/X11/lib
  -L/usr/pkg/lib try.c -lutil -lbind -lgdbm -ldl -lm -lc -liconv

  and I got the following output:

  ld: cannot find -lgdbm
  I can't compile the test program.
  You have a BIG problem.  Shall I abort Configure [y]
  Ok.  Stopping Configure.
  *** Error code 1


I do have a libgdbm that I could buildlink with.

That appears to be the problem maybe.

I compared the Configure output from two months ago when it worked and

 Checking for optional libraries...
-What libraries to use? [-lutil -lbind -ldl -lm -lc]
+What libraries to use? [-lutil -lbind -lgdbm -ldl -lm -lc -liconv]
 Checking your choice of C compiler and flags for coherency...
-Checking to see how big your integers are...
-off_t found.

   Jeremy C. Reed