Subject: Re: USE_GCC_SHLIB makes depends on wrong gcc
To: Jeremy C. Reed <>
From: grant beattie <>
List: tech-pkg
Date: 12/04/2003 16:10:43
On Wed, Dec 03, 2003 at 09:08:44PM -0800, Jeremy C. Reed wrote:

> > under what circumstances? could you provide an example?
> The only gcc I have is gcc3-c-3.3.2 and gcc-c++-3.3.2 as installed from
> pkgsrc.
> I defined USE_GCC_SHLIB in libtool-base just to test it. That is when I
> saw it "Registering depends: gcc>=2.95.3". Which is wrong, because I hope
> the reference would register what I really have. Because if I install on
> another system, it will bring in the wrong dependency.


see my message <20031203230228.GK12841@fang> in a recent thread - nobody
who cares about lang/gcc3-* has done the required work to properly
support those packages in the pkgsrc infrastructure yet.