Subject: patches for security/gnupg on 1.5.x
To: None <>
From: Klaus Heinz <>
List: tech-pkg
Date: 11/27/2003 22:13:10
[ Bcc: netbsd-users, for a wider audience ]

the current package gnupg-1.2.3nb1 does not build on 1.5.x (probably
both on 32-bit and 64-bit machines) due to a missing definition of
UINT64_C in /usr/include/inttypes.h.

Please, could someone test the patches I intend to feed back to the
maintainers on a 64-bit machine with 1.5.x (64-bit 1.6.x or current
wouldn't be bad either)? The complete package is available as

During configure stage the output should show

  checking for inttypes.h... (cached) yes
  checking for uint64_t... yes
  checking whether UINT64_C is defined... no

For 1.6.x/-current the last line should show "yes".

'make test' should be successful, of course.