Subject: Re: trouble compiling gcc3 on IRIX64 6.5.20m
To: Michal Pasternak <>
From: Ryan Cresawn <>
List: tech-pkg
Date: 11/24/2003 23:04:14

I found the file which defines 'LONG_MIN' under '/usr/include' per
your suggestion, though I used a slightly different method than you
suggested because I ran into a problem due to the number of arguments
being passed to 'grep'.  This command worked for me:

  # find . -exec grep LONG_MIN {} \;

This is the result:

  #define LONG_MIN        (-2147483647-1)         /* min value of a "long int" */
  #define LONG_MIN        (-9223372036854775807L-1L) /* min value of a "long int" */
  #define LLONG_MIN       (-9223372036854775807LL-1LL)
  #define LONGLONG_MIN        (-9223372036854775807LL-1LL) /* min "long long int" */

I changed 'fibheap.c' per your recommendation and the compilation
continued for a while longer, though it again has failed and here is
the latest failure point.

  /usr/pkgsrc/lang/gcc3/work/gcc-3.3/gcc/xgcc -B/usr/pkgsrc/lang/gcc3/work/gcc-3.3/gcc/ -B/usr/pkg/gcc-3.3/mips-sgi-irix6.5/bin/ -B/usr/pkg/gcc-3.3/mips-sgi-irix6.5/lib/ -isystem /usr/pkg/gcc-3.3/mips-sgi-irix6.5/include -c -DHAVE_CONFIG_H -O2 -O2 -I/usr/pkg/include -I. -I./../../include  -W -Wall -Wtraditional -pedantic getpwd.c -o getpwd.o
  getpwd.c: In function getpwd':
  getpwd.c:74: error: storage size of dotstat' isn't known
  getpwd.c:74: error: storage size of pwdstat' isn't known
  getpwd.c:78: warning: implicit declaration of function getenv'
  getpwd.c:78: warning: assignment makes pointer from integer without a cast
  getpwd.c:80: warning: implicit declaration of function stat'
  getpwd.c:86: warning: implicit declaration of function getcwd'
  getpwd.c:89: warning: implicit declaration of function free'
  getpwd.c:74: warning: unused variable dotstat'
  getpwd.c:74: warning: unused variable pwdstat'
  gmake[1]: *** [getpwd.o] Error 1
  gmake[1]: Leaving directory
  gmake: *** [all-target-libiberty] Error 2
  *** Error code 2

  bmake: stopped in /usr/pkgsrc/lang/gcc3
  *** Error code 1

  bmake: stopped in /usr/pkgsrc/lang/gcc3

Is this normal to have so many problems or is something seriously
broken with my IRIX installation or my build environment?


On Mon, Nov 24, 2003 at 11:09:09PM +0100, Michal Pasternak wrote:
> Ryan Cresawn [Mon, Nov 24, 2003 at 05:01:33PM -0500]:
> > Oops!  So I ran 'bmake' again and all of the output is below.  It's
> Ryan, 
> the only lines, that are important are the ones which start with "error:" at
> the beginning
> > fibheap.c: In function fibheap_delete_node':
> > fibheap.c:285: error: LONG_MIN' undeclared (first use in this function)
> > fibheap.c:285: error: (Each undeclared identifier is reported only once
> > fibheap.c:285: error: for each function it appears in.)
> > fibheap.c: In function fibheap_delete':
> Look, which file of /usr/include defines LONG_MIN:
>       cd /usr/include
>       grep LONG_MIN `find * -type f`
> Edit fibheap.c to make it include that file: add to fibheap.c:
>      #include <nameofthefilewithout/usr/include.h>
> Take care,     
> -- 
> Michal Pasternak ::