Subject: Re: gcc 2.95.3 issue
To: None <firstname.lastname@example.org>
From: Michael Santos <email@example.com>
Date: 11/24/2003 08:39:25
On Sun, Nov 23, 2003 at 09:02:54PM +0100, Thomas Klausner wrote:
> On Sun, Nov 23, 2003 at 12:10:34AM -0800, David S. wrote:
> > I can confirm this. I built 'pkgsrc/security/sfs' on a -current system
> > (i386 1.6ZE) and got gcc 2.95.3 too. The build for that crapped out on
> > 'loop.c'. The fix is trivial, but why do should I need gcc 2.95.3?
> > Lodking at the 'sfs' Makefile, I'm not ever sure how this superfluous
> > dependcy is enforced.
> There was a superfluous USE_PKGSRC_GCC line in there -- I
> removed it, since the package builds fine with gcc2 and
> gcc3 from the base system.
sfs requires gcc >2.95.1 to build; so USE_PKGSRC_GCC is needed at least
on NetBSD 1.5 (egcs-2.91.66).