Subject: Re: needing libtool to be rebuilt
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 11/21/2003 11:42:33
On Fri, 21 Nov 2003, Johnny C. Lam wrote:

> IIRC, libtool is _compiler_ specific, and to be absolutely safe, you
> need to rebuild it if you change your compiler.  -current uses GCC 3.x
> while netbsd-1-6 uses GCC 2.95.x, which might explain why rebuilding
> libtool was the solution to the problem in the PR.
> We could definitely write some checks for the proper compiler version
> when a package uses libtool, but I think as a start we should just
> educate -current users that they should always, _always_ rebuild
> libtool if they moved from a netbsd-1-6 system, even if it means
> they'll need to rebuild KDE3 from scratch.

Where should this be documented?

MESSAGE file for libtool-base?
MESSAGE.NetBSD file for libtool-base?
Documentation/current/index.html webpage? "Specific problems"

   Jeremy C. Reed