Subject: Re: Audio problems.
To: None <>
From: Adam K Kirchhoff <>
List: tech-pkg
Date: 11/18/2003 11:07:34
I guess I'm the only one interested in getting this working, huh?  Well,
that's alright, I'll take a stab at fixing this myself, but any pointers
would be appreciated.


On Sat, 15 Nov 2003, Adam K Kirchhoff wrote:

> I'm having problems with the yds driver and the xgalaga package.
> Basically, the audio for the game stutters horrendously for a few seconds,
> and then the sound server that xgalaga uses core dumps.  Running gdb on
> the core file simply reveals the following:
> [ adamk@sorrow - ~ ]: gdb --core xgal.sndsrv.linu.core
> GNU gdb 5.3nb1
> Copyright 2002 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License, and you are
> welcome to change it and/or distribute copies of it under certain conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for details.
> This GDB was configured as "i386--netbsdelf".
> Core was generated by `xgal.sndsrv.linu'.
> Program terminated with signal 11, Segmentation fault.
> #0  0x080491e9 in ?? ()
> (gdb) quit
> This causes xgalaga to die with "Broken pipe" error.  Interestingly, the
> stuttering also happens when I use the "-nosound" flag for xgalaga, though
> the game never dies in that case (the stuttering will continue for however
> long I play, though).
> This does not happen with the emuxki and eap drivers, making me think this
> is an issue with the driver, and not the package but since I have no idea
> how to confirm this, I thought I'd e-mail both the tech-kern and teck-pkg
> lists.
> Can anyone advise me on how to get this fixed?
> Adam